`synchronize': wrong number of arguments (5 for 0) (ArgumentError)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

`synchronize': wrong number of arguments (5 for 0) (ArgumentError)

Harry Vangberg-2

Hey

I just rewrote my app for 0.8.1 - it runs fine on my local box, but
when I try to start it on the server I get this:

audioguiden@tlf:~/audioguiden/ivr$ ./adhearsion/bin/ahn start .
/home/audioguiden/audioguiden/gui/vendor/rails/activerecord/lib/
active_record/connection_adapters/abstract/connection_pool.rb:218:in
`synchronize': wrong number of arguments (5 for 0) (ArgumentError)
        from /home/audioguiden/audioguiden/gui/vendor/rails/
activerecord/lib/active_record/connection_adapters/abstract/
connection_pool.rb:218
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
31:in `gem_original_require'
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
active_support/dependencies.rb:510:in `require'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
active_support/dependencies.rb:355:in `new_constants_in'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
active_support/dependencies.rb:510:in `require'
        from /home/audioguiden/audioguiden/gui/vendor/rails/
activerecord/lib/active_record/connection_adapters/abstract_adapter.rb:
10
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
31:in `gem_original_require'
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
active_support/dependencies.rb:510:in `require'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
active_support/dependencies.rb:355:in `new_constants_in'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
active_support/dependencies.rb:510:in `require'
        from /home/audioguiden/audioguiden/gui/vendor/rails/
activerecord/lib/active_record.rb:76
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
31:in `gem_original_require'
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
active_support/dependencies.rb:510:in `require'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
active_support/dependencies.rb:355:in `new_constants_in'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
active_support/dependencies.rb:510:in `require'
        from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
railties/lib/initializer.rb:256:in `require_frameworks'
        from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
railties/lib/initializer.rb:256:in `each'
        from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
railties/lib/initializer.rb:256:in `require_frameworks'
        from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
railties/lib/initializer.rb:133:in `process'
        from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
railties/lib/initializer.rb:112:in `send'
        from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
railties/lib/initializer.rb:112:in `run'
        from /home/audioguiden/audioguiden/gui/config/environment.rb:
13
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
31:in `gem_original_require'
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
31:in `require'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
active_support/dependencies.rb:510:in `require'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
active_support/dependencies.rb:355:in `new_constants_in'
        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
active_support/dependencies.rb:510:in `require'
        from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
adhearsion/initializer/rails.rb:33:in `load_rails'
        from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
adhearsion/initializer/rails.rb:18:in `start'
        from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
adhearsion/initializer.rb:272:in `init_modules'
        from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
adhearsion/initializer.rb:135:in `start'
        from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
adhearsion/initializer.rb:92:in `start'
        from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
adhearsion/cli.rb:129:in `start'
        from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
adhearsion/cli.rb:19:in `send'
        from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
adhearsion/cli.rb:19:in `execute!'
        from ./adhearsion/bin/ahn:28

I've vendored Adhearsion. For what its worth the Rails app I'm
integrating with runs just fine.
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "Adhearsion" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/adhearsion?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: `synchronize': wrong number of arguments (5 for 0) (ArgumentError)

JasonGoecke

Are you still having this problem?

On Mar 4, 4:28 am, Harry Vangberg <[hidden email]> wrote:

> Hey
>
> I just rewrote my app for 0.8.1 - it runs fine on my local box, but
> when I try to start it on the server I get this:
>
> audioguiden@tlf:~/audioguiden/ivr$ ./adhearsion/bin/ahn start .
> /home/audioguiden/audioguiden/gui/vendor/rails/activerecord/lib/
> active_record/connection_adapters/abstract/connection_pool.rb:218:in
> `synchronize': wrong number of arguments (5 for 0) (ArgumentError)
>         from /home/audioguiden/audioguiden/gui/vendor/rails/
> activerecord/lib/active_record/connection_adapters/abstract/
> connection_pool.rb:218
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `gem_original_require'
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:355:in `new_constants_in'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /home/audioguiden/audioguiden/gui/vendor/rails/
> activerecord/lib/active_record/connection_adapters/abstract_adapter.rb:
> 10
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `gem_original_require'
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:355:in `new_constants_in'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /home/audioguiden/audioguiden/gui/vendor/rails/
> activerecord/lib/active_record.rb:76
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `gem_original_require'
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:355:in `new_constants_in'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
> railties/lib/initializer.rb:256:in `require_frameworks'
>         from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
> railties/lib/initializer.rb:256:in `each'
>         from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
> railties/lib/initializer.rb:256:in `require_frameworks'
>         from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
> railties/lib/initializer.rb:133:in `process'
>         from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
> railties/lib/initializer.rb:112:in `send'
>         from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
> railties/lib/initializer.rb:112:in `run'
>         from /home/audioguiden/audioguiden/gui/config/environment.rb:
> 13
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `gem_original_require'
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:355:in `new_constants_in'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/initializer/rails.rb:33:in `load_rails'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/initializer/rails.rb:18:in `start'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/initializer.rb:272:in `init_modules'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/initializer.rb:135:in `start'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/initializer.rb:92:in `start'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/cli.rb:129:in `start'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/cli.rb:19:in `send'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/cli.rb:19:in `execute!'
>         from ./adhearsion/bin/ahn:28
>
> I've vendored Adhearsion. For what its worth the Rails app I'm
> integrating with runs just fine.
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "Adhearsion" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/adhearsion?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: `synchronize': wrong number of arguments (5 for 0) (ArgumentError)

Harry Vangberg-2
Nope, it was due to some stuff with different Rails versions. Vendoring Rails fixed it.

2009/3/14 JasonGoecke <[hidden email]>

Are you still having this problem?

On Mar 4, 4:28 am, Harry Vangberg <[hidden email]> wrote:
> Hey
>
> I just rewrote my app for 0.8.1 - it runs fine on my local box, but
> when I try to start it on the server I get this:
>
> audioguiden@tlf:~/audioguiden/ivr$ ./adhearsion/bin/ahn start .
> /home/audioguiden/audioguiden/gui/vendor/rails/activerecord/lib/
> active_record/connection_adapters/abstract/connection_pool.rb:218:in
> `synchronize': wrong number of arguments (5 for 0) (ArgumentError)
>         from /home/audioguiden/audioguiden/gui/vendor/rails/
> activerecord/lib/active_record/connection_adapters/abstract/
> connection_pool.rb:218
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `gem_original_require'
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:355:in `new_constants_in'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /home/audioguiden/audioguiden/gui/vendor/rails/
> activerecord/lib/active_record/connection_adapters/abstract_adapter.rb:
> 10
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `gem_original_require'
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:355:in `new_constants_in'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /home/audioguiden/audioguiden/gui/vendor/rails/
> activerecord/lib/active_record.rb:76
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `gem_original_require'
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:355:in `new_constants_in'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
> railties/lib/initializer.rb:256:in `require_frameworks'
>         from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
> railties/lib/initializer.rb:256:in `each'
>         from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
> railties/lib/initializer.rb:256:in `require_frameworks'
>         from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
> railties/lib/initializer.rb:133:in `process'
>         from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
> railties/lib/initializer.rb:112:in `send'
>         from /home/audioguiden/audioguiden/gui/config/../vendor/rails/
> railties/lib/initializer.rb:112:in `run'
>         from /home/audioguiden/audioguiden/gui/config/environment.rb:
> 13
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `gem_original_require'
>         from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:355:in `new_constants_in'
>         from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.2/lib/
> active_support/dependencies.rb:510:in `require'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/initializer/rails.rb:33:in `load_rails'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/initializer/rails.rb:18:in `start'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/initializer.rb:272:in `init_modules'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/initializer.rb:135:in `start'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/initializer.rb:92:in `start'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/cli.rb:129:in `start'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/cli.rb:19:in `send'
>         from /home/audioguiden/audioguiden/ivr/adhearsion/lib/
> adhearsion/cli.rb:19:in `execute!'
>         from ./adhearsion/bin/ahn:28
>
> I've vendored Adhearsion. For what its worth the Rails app I'm
> integrating with runs just fine.



--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "Adhearsion" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/adhearsion?hl=en
-~----------~----~----~----~------~----~------~--~---